Checkout pages down

Incident Report for Seeking Alpha

Resolved

This incident has been resolved.
Posted Apr 17, 2023 - 16:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2023 - 16:09 UTC

Identified

Due to issues at the upstream service provider, the purchase of new subscriptions is temporary unavailable. We are actively monitoring the issue and will update as soon as the status changes.
Posted Apr 17, 2023 - 15:39 UTC