Website down
Incident Report for Seeking Alpha
Resolved
This incident has been resolved.
Posted Mar 12, 2022 - 21:56 UTC
Update
We limited the outage to symbol pages only
Posted Mar 12, 2022 - 17:40 UTC
Identified
A scheduled financial data migration caused global website slowness to a halt
Posted Mar 12, 2022 - 14:50 UTC
This incident affected: Website, Mobile Apps, and Contributors Forum.